[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [RFC 12/42] pc: initialize legacy hotplug only for 2.6 and older machine types



On Thu, May 12, 2016 at 07:52:23 -0300, Eduardo Habkost wrote:
> I don't think we should do that, unless users already had time to
> update their scripts and libvirt had time to implement code
> supporting the new method.
> 
> I believe libvirt (and people's scripts) use maxcpus only when
> they want CPU hotplug, so making max_cpus > smp_cpus enable CPU
> hotplug implicitly would probably solve the compatibility issue.

Libvirt uses maxcpus only if the configuration explicitly has less
active cpus than the maximum number. This option would be the best IMO.

> If we want to deprecate the use of maxcpus to enable CPU hotplug,
> then we can make it print a warning for a few releases, so people
> have time to update their code.

At that point libvirt also needs a way to detect that the new argument
is supported by qemu, so we can start passing it on the command line
basically every time we now pass 'maxcpus'.

The warning will get most probably ignored by people using libvirt as
the stdout/err of qemu is not visible to them.

Peter

Attachment: signature.asc
Description: Digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]