[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH 0/3] esx: improve virtualHW > 7 handling.



Hello,

The following patches are for issues found when using libvirt to
create/manage VMs on ESXi hosts (5.5 and 6). The first patch addresses
a fairly common issue with creating VMs on ESXi with SCSI controllers.
The other two are to less common but work around known ESX issues e.g.
4TB drive size limit and vMotion compatibility.

Dawid Zamirski (3):
  esx: add pciBridge devices when SCSI is used
  esx: Add VMCI device for virtualHW >= 7
  esx: use newer virtualHW version for 5.1+ hosts

 src/esx/esx_vi.c                                   | 17 ++++++++++++++
 src/vmx/vmx.c                                      | 27 ++++++++++++++++++++++
 tests/xml2vmxdata/xml2vmx-fusion-in-the-wild-1.vmx | 14 +++++++++++
 .../xml2vmxdata/xml2vmx-serial-network-client.vmx  |  1 +
 .../xml2vmxdata/xml2vmx-serial-network-server.vmx  |  1 +
 tests/xml2vmxdata/xml2vmx-ws-in-the-wild-1.vmx     | 14 +++++++++++
 tests/xml2vmxdata/xml2vmx-ws-in-the-wild-2.vmx     | 14 +++++++++++
 7 files changed, 88 insertions(+)

-- 
2.7.4


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]