[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH 3/3] esx: use newer virtualHW version for 5.1+ hosts



This is because there's a known issue where ESX will refuse to attach
drives bigger than 4TB when virtualHW < 9. Therefore, to avoid that
use the higher virtualHW for hosts that support it.

---
https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2054952

 src/esx/esx_vi.c | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

diff --git a/src/esx/esx_vi.c b/src/esx/esx_vi.c
index f7eeeb5..bf6f228 100644
--- a/src/esx/esx_vi.c
+++ b/src/esx/esx_vi.c
@@ -4712,6 +4712,7 @@ esxVI_ProductVersionToDefaultVirtualHWVersion(esxVI_ProductLine productLine,
 {
     /* product version == 1000000 * major + 1000 * minor + micro */
     int major = productVersion / 1000000;
+    int minor = productVersion / 1000 - major * 1000;
 
     /*
      * virtualHW.version compatibility matrix:
@@ -4738,6 +4739,14 @@ esxVI_ProductVersionToDefaultVirtualHWVersion(esxVI_ProductLine productLine,
             return 7;
 
           case 5:
+            if (minor < 5)
+                return 9;
+
+            return 10;
+
+          case 6:
+            return 10;
+
           default:
             return 8;
         }
@@ -4751,6 +4760,14 @@ esxVI_ProductVersionToDefaultVirtualHWVersion(esxVI_ProductLine productLine,
             return 7;
 
           case 5:
+            if (minor < 5)
+                return 9;
+
+            return 10;
+
+          case 6:
+            return 10;
+
           default:
             return 8;
         }
-- 
2.7.4


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]