[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] Mention the min duration for nodesuspend explicitly



Although currently this is documented in virsh man page
and virsh help, the expicit mention in the error message
is helful for tools using the API directly.

Signed-off-by: Nitesh Konkar <nitkon12 linux vnet ibm com>
---
 src/util/virnodesuspend.c | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/src/util/virnodesuspend.c b/src/util/virnodesuspend.c
index 8bb8d93..71b2d4c 100644
--- a/src/util/virnodesuspend.c
+++ b/src/util/virnodesuspend.c
@@ -76,7 +76,9 @@ static int virNodeSuspendSetNodeWakeup(unsigned long long alarmTime)
     int ret = -1;
 
     if (alarmTime < MIN_TIME_REQ_FOR_SUSPEND) {
-        virReportError(VIR_ERR_INVALID_ARG, "%s", _("Suspend duration is too short"));
+        virReportError(VIR_ERR_INVALID_ARG,
+                       _("Suspend duration is too short, must be at least %u seconds"),
+                       MIN_TIME_REQ_FOR_SUSPEND);
         return -1;
     }
 
-- 
2.1.0


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]