[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH v2] cpu: fix typo: rename __kvm_hv_spinlock to __kvm_hv_spinlocks



On Tue, Jan 31, 2017 at 17:12:13 +0300, Maxim Nestratov wrote:
> Strings associated with virDomainHyperv values in domain_conf.c are used to
> construct HyperV CPU features names to be compared with names defined in
> cpu_x86_data.h and the names for HyperV "spinlocks" feature don't match.
> This leads to a misleading warning:
> "host doesn't support hyperv 'spinlocks' feature" even when it's supported.
> Let's fix it and rename along with it VIR_CPU_x86_KVM_HV_SPINLOCK to
> VIR_CPU_x86_KVM_HV_SPINLOCKS.
> 
> Signed-off-by: Maxim Nestratov <mnestratov virtuozzo com>
> ---
>  src/cpu/cpu_x86.c      | 4 ++--
>  src/cpu/cpu_x86_data.h | 8 +++++++-
>  2 files changed, 9 insertions(+), 3 deletions(-)

ACK and pushed. I just updated the comment to explicitly mention
virDomainHyperv.

Jirka


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]