[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] Fix libvirt-driver-libxl check



Fix saving CFLAGS in LIBVIRT_DRIVER_CHECK_LIBXL - LIBVIRT_CHECK_LIB will
override old_CFLAGS, so use a different name.

Signed-off-by: Marek Marczykowski-Górecki <marmarek invisiblethingslab com>
---
 m4/virt-driver-libxl.m4 | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/m4/virt-driver-libxl.m4 b/m4/virt-driver-libxl.m4
index 2cc1c062d8..90338eb306 100644
--- a/m4/virt-driver-libxl.m4
+++ b/m4/virt-driver-libxl.m4
@@ -46,10 +46,10 @@ AC_DEFUN([LIBVIRT_DRIVER_CHECK_LIBXL], [
     dnl The libxl driver will make use of this new parameter for specifying
     dnl the Xen migration stream version. Specify LIBXL_API_VERSION to trigger
     dnl an error if there is too old xenlight
-    old_CFLAGS="$CFLAGS"
+    libxlold_CFLAGS="$CFLAGS"
     CFLAGS="$CFLAGS $LIBXL_API_VERSION"
     LIBVIRT_CHECK_LIB([LIBXL], [xenlight], [libxl_ctx_alloc], [libxl.h], [fail="1"])
-    CFLAGS="$old_CFLAGS"
+    CFLAGS="$libxlold_CFLAGS"
 
     if test $fail = 1; then
       AC_MSG_ERROR([You must install the libxl Library from Xen >= 4.4 to compile libxenlight driver with -lxl])
-- 
2.17.1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]