[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH 6/6] qemu: domain: Fix machine type version check for 'isa-fdc' usage



Starting from pc-q35-2.4 the floppy controller is not enabled by
default. Fix the version check so that it does not match 2.11 as being
2.1.

Signed-off-by: Peter Krempa <pkrempa redhat com>
---
 src/qemu/qemu_domain.c                                       | 12 ++++++++----
 .../qemuxml2argvdata/disk-floppy-q35-2_11.x86_64-latest.args |  4 +---
 2 files changed, 9 insertions(+), 7 deletions(-)

diff --git a/src/qemu/qemu_domain.c b/src/qemu/qemu_domain.c
index a5d81f863b..654cd4b872 100644
--- a/src/qemu/qemu_domain.c
+++ b/src/qemu/qemu_domain.c
@@ -9427,10 +9427,14 @@ qemuDomainMachineNeedsFDC(const char *machine)

     if (p) {
         if (STRPREFIX(p, "1.") ||
-            STRPREFIX(p, "2.0") ||
-            STRPREFIX(p, "2.1") ||
-            STRPREFIX(p, "2.2") ||
-            STRPREFIX(p, "2.3"))
+            STREQ(p, "2.0") ||
+            STRPREFIX(p, "2.0-") ||
+            STREQ(p, "2.1") ||
+            STRPREFIX(p, "2.1-") ||
+            STREQ(p, "2.2") ||
+            STRPREFIX(p, "2.2-") ||
+            STREQ(p, "2.3") ||
+            STRPREFIX(p, "2.3-"))
             return false;
         return true;
     }
diff --git a/tests/qemuxml2argvdata/disk-floppy-q35-2_11.x86_64-latest.args b/tests/qemuxml2argvdata/disk-floppy-q35-2_11.x86_64-latest.args
index e38f7040ec..17abe9a989 100644
--- a/tests/qemuxml2argvdata/disk-floppy-q35-2_11.x86_64-latest.args
+++ b/tests/qemuxml2argvdata/disk-floppy-q35-2_11.x86_64-latest.args
@@ -29,9 +29,7 @@ addr=0x1 \
 -device qemu-xhci,id=usb,bus=pci.1,addr=0x0 \
 -drive file=/tmp/firmware.img,format=raw,if=none,id=drive-fdc0-0-0 \
 -drive file=/tmp/data.img,format=qcow2,if=none,id=drive-fdc0-0-1 \
--global isa-fdc.driveA=drive-fdc0-0-0 \
--global isa-fdc.bootindexA=1 \
--global isa-fdc.driveB=drive-fdc0-0-1 \
+-device isa-fdc,driveA=drive-fdc0-0-0,bootindexA=1,driveB=drive-fdc0-0-1 \
 -sandbox on,obsolete=deny,elevateprivileges=deny,spawn=deny,\
 resourcecontrol=deny \
 -msg timestamp=on
-- 
2.16.2


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]