[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [jenkins-ci PATCH 1/6] guests: Don't prepare Ubuntu 16.04 for virt-manager



On Fri, Aug 10, 2018 at 12:24:46PM +0200, Andrea Bolognani wrote:
> On Fri, 2018-08-10 at 10:31 +0200, Erik Skultety wrote:
> > On Thu, Aug 09, 2018 at 03:16:38PM +0200, Andrea Bolognani wrote:
> > > virt-manager can't be built successfully on the
> > > platform, so we shouldn't install the corresponding
> > > build dependencies.
> >
> > For the sake of history, it would be nice to be a bit more detailed as why it
> > can't be built on a specific distro.
>
> As mentioned on IRC, whenever we have to introduce an exception
> to our general "build every project on every platform" mantra, it's
> certainly useful to document the rationale. We have a few examples
> of that happening already, but there's plenty of room for
> improvement as well.
>
> I think that information belongs to the code rather than to the
> commit messages, though. So would you be okay if I pushed these
> patches as-is and posted a follow-up series that adds information
> about all exceptions as comments in the relevant files?

To be honest, I kinda was counting on you sending a follow-up regardless of
my comment, because as you said, it's always better to document this properly
in relevant files :). At the same time though, I needed to experience e.g. the
failure with missing xz-static on CentOS 7 myself to actually figure out, what
it is that makes the build fail. So, even though I'm not insisting on you
changing the commit messages, I think that dropping a note about specific
missing requirements for a successful build as a justification for those 2
patches in play won't add much work. Anyhow, my RB still stands.

Erik


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]