[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [libvirt-glib][PATCH] Use new GObject define macros with private



On Fri, Aug 10, 2018 at 01:16:20PM +0200, Michal Privoznik wrote:
> On 08/10/2018 01:03 PM, Michal Privoznik wrote:
> > On 08/10/2018 11:38 AM, Daniel P. Berrangé wrote:
> >> On Fri, Aug 10, 2018 at 11:29:30AM +0200, Michal Privoznik wrote:
> >>> G_ADD_PRIVATE was added in 2.38 and older functions are getting deprecated:
> >>> https://gitlab.gnome.org/GNOME/glib/merge_requests/7/commits
> >>
> >> Our min glib2 version is currently 2.36, since that's what RHEL-7 has.
> > 
> > That's a bummer. But okay, I'll keep the patch in my local repo until
> > RHEL rebases. But this is breaking build in more modern distros (e.g.
> > Fedora rawhide).
> > 
> > Disabling warnings looks like a temporal workaround to me.
> > 
> 
> Hold on, spice did the same change just a while ago:
> 
> https://cgit.freedesktop.org/spice/spice-gtk/commit/?id=950cf050aed637f8cb72a0f5899f75eeeffd2ebd
> 
> and they are only requiring 2.28 :-) Nevermind.

Looks like they just effectively bumped their min version without
realizing it !


Regards,
Daniel
-- 
|: https://berrange.com      -o-    https://www.flickr.com/photos/dberrange :|
|: https://libvirt.org         -o-            https://fstop138.berrange.com :|
|: https://entangle-photo.org    -o-    https://www.instagram.com/dberrange :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]