[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [dbus PATCH 3/3] configure: Find flake8 on FreeBSD



The newest version available from ports at the moment
is built against Python 3.6 and is thus installed as
flake8-3.6 on the platform. This makes syntax-check
work out of the box on FreeBSD.

Signed-off-by: Andrea Bolognani <abologna redhat com>
---
 configure.ac | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/configure.ac b/configure.ac
index 8722255..ccb02a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,7 +36,7 @@ AC_PROG_MKDIR_P
 AM_PROG_CC_C_O
 AC_PROG_CC_STDC
 AC_PROG_LIBTOOL
-AC_PATH_PROGS([FLAKE8], [flake8])
+AC_PATH_PROGS([FLAKE8], [flake8 flake8-3.6])
 
 PKG_CHECK_MODULES([GIO2], [gio-unix-2.0 >= $GLIB2_REQUIRED])
 PKG_CHECK_MODULES([GLIB2], [glib-2.0 >= $GLIB2_REQUIRED])
-- 
2.17.1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]