[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [jenkins-ci PATCH 1/2] guests: Install flake8 for libvirt-dbus



It is required to run 'make syntax-check'.

Signed-off-by: Andrea Bolognani <abologna redhat com>
---
 guests/vars/mappings.yml              | 7 +++++++
 guests/vars/projects/libvirt-dbus.yml | 1 +
 2 files changed, 8 insertions(+)

diff --git a/guests/vars/mappings.yml b/guests/vars/mappings.yml
index 21948fb..59a4b01 100644
--- a/guests/vars/mappings.yml
+++ b/guests/vars/mappings.yml
@@ -100,6 +100,13 @@ mappings:
     default: ebtables
     FreeBSD:
 
+  flake8:
+    deb: flake8
+    pkg: py36-flake8
+    rpm: python3-flake8
+    CentOS7:
+    Debian8:
+
   fuse:
     deb: libfuse-dev
     pkg: fusefs-libs
diff --git a/guests/vars/projects/libvirt-dbus.yml b/guests/vars/projects/libvirt-dbus.yml
index ebb346e..22052de 100644
--- a/guests/vars/projects/libvirt-dbus.yml
+++ b/guests/vars/projects/libvirt-dbus.yml
@@ -1,5 +1,6 @@
 ---
 packages:
+  - flake8
   - glib2
   - python3
   - python3-dbus
-- 
2.17.1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]