[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 1/4] tests: sev: Test launch-security with specific QEMU version



On Wed, Aug 15, 2018 at 17:02:05 +0200, Erik Skultety wrote:
> In order to test SEV we need real QEMU capabilities. Ideally, this would
> be tested with -latest capabilities, however, our capabilities are
> currently tied to Intel HW, even the 2.12.0 containing SEV were edited by
> hand, so we can only use that one for now, as splitting the capabilities
> according to the vendor is a refactor for another day. The need for real

Yeah, that won't be pretty. Or will require adding a new testing macro
for non-mainstream arches.

> capabilities comes from the extended SEV platform data (PDH, cbitpos,
> etc.) we'll need to cache/parse.
> 
> Signed-off-by: Erik Skultety <eskultet redhat com>
> ---
>  ...ev.args => launch-security-sev.x86_64-2.12.0.args} | 19 ++++++++++++-------
>  tests/qemuxml2argvtest.c                              |  4 +---
>  2 files changed, 13 insertions(+), 10 deletions(-)
>  rename tests/qemuxml2argvdata/{launch-security-sev.args => launch-security-sev.x86_64-2.12.0.args} (54%)

ACK, it's good to see more of the real caps tests.

Attachment: signature.asc
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]