[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH v2 0/3] ui: remove deprecated UI frontends



We deprecated GTK2 and SDL1.2 in the 2.12.0 release, so they are able to
be removed entirely in the 3.1.0 release. The min GTK3 version can also
be bumped up based the distros we aim to support.

Note that before this can merge, the openbsd VM test image needs to be
updated to have SDL2, as openbsd build mandates SDL availability.

The freebsd & netbsd images should also be updated, but they are not
build blockers as they automatically disable SDL

Changed in v2:

 - Rebased to resolve conflicts

Daniel P. Berrangé (3):
  ui: remove support for GTK2 in favour of GTK3
  ui: increase min required GTK3 version to 3.14.0
  ui: remove support for SDL1.2 in favour of SDL2

 configure              |  111 +----
 include/ui/gtk.h       |    9 -
 qemu-deprecated.texi   |   16 -
 ui/Makefile.objs       |    5 -
 ui/gtk-egl.c           |   10 +-
 ui/gtk.c               |  202 +-------
 ui/sdl.c               | 1027 ----------------------------------------
 ui/sdl_zoom.c          |   93 ----
 ui/sdl_zoom.h          |   25 -
 ui/sdl_zoom_template.h |  219 ---------
 10 files changed, 33 insertions(+), 1684 deletions(-)
 delete mode 100644 ui/sdl.c
 delete mode 100644 ui/sdl_zoom.c
 delete mode 100644 ui/sdl_zoom.h
 delete mode 100644 ui/sdl_zoom_template.h

-- 
2.17.1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]