[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [Qemu-devel] [PATCH v2 0/3] ui: remove deprecated UI frontends



On Wed, 2018-08-22 at 14:15 +0100, Daniel P. Berrangé wrote:
> We deprecated GTK2 and SDL1.2 in the 2.12.0 release, so they are able to
> be removed entirely in the 3.1.0 release. The min GTK3 version can also
> be bumped up based the distros we aim to support.
> 
> Note that before this can merge, the openbsd VM test image needs to be
> updated to have SDL2, as openbsd build mandates SDL availability.
> 
> The freebsd & netbsd images should also be updated, but they are not
> build blockers as they automatically disable SDL
> 
> Changed in v2:
> 
>  - Rebased to resolve conflicts
> 
> Daniel P. Berrangé (3):
>   ui: remove support for GTK2 in favour of GTK3
>   ui: increase min required GTK3 version to 3.14.0
>   ui: remove support for SDL1.2 in favour of SDL2

Nit: you might want to tweak some parts of the commit messages,
because they're no longer accurate...

> The GTK 3.0 release was made in Feb, 2011:
> 
>   https://blog.gtk.org/2011/02/10/gtk-3-0-released/
> 
> That will soon be 7 years ago, which is enough time to consider
> the 3.x series widely supported.

It's been more than 7 years now.

> The SDL 2.0 release was made in Aug, 2013:
> 
>   https://www.libsdl.org/release/
> 
> That will soon be 4 + 1/2 years ago, which is enough time to consider
> the 2.0 series widely supported.

It's been more than 5 years now.

-- 
Andrea Bolognani / Red Hat / Virtualization


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]