[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH v3 0/4] rpc: fixing compilation error due to deprecated functions.



I agree about versioning and stability.
The idea behind the patches is just predict the future problems related to libssh.
Specially to discuss changes associated with deprecated functions.
And also specially because we have several Linux OSes keeping its own package versioning.
We would not like to break anything.
I will split this serie and wait for 0.9.0 stable release.

Thanks to review, Andrea. ;-)

Em ter, 18 de dez de 2018 às 12:01, Andrea Bolognani <abologna redhat com> escreveu:
On Sat, 2018-11-24 at 03:52 +0800, Julio Faracco wrote:
> After 0.8.0 release, libssh deprecated some functions like:
> ssh_is_server_known() and ssh_write_knownhost().

This is not accurate: 0.8.5 was released less than two months ago
and does not consider any of the functions you listed as deprecated;
the deprecation is indeed in place on the master branch, which will
eventually be released as 0.9.0 or whatever.

Speaking of which, I'm not entirely convinced being *this* proactive
with respect to libssh deprecations is useful when we could at least
wait for the next stable release to be out. I'll review the patches
in more detail regardless :)

--
Andrea Bolognani / Red Hat / Virtualization


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]