[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [jenkins-ci PATCH] Don't run libvirt-dbus-syntax-check on FreeBSD



On Wed, 2018-11-14 at 13:12 +0000, Daniel P. Berrangé wrote:
> On Wed, Nov 14, 2018 at 01:43:10PM +0100, Andrea Bolognani wrote:
> > flake8 wants 'pyflakes<1.7.0,>=1.5.0', but all FreeBSD
> > releases ship pyflakes 2.0.0 these days.
> 
> This rationale doesn't make sense given that I see Fedora has
> flake8 which is happily using pyflakes 2.0.0
> 
>    # rpm -q python3-flake8 python3-pyflakes
>    python3-flake8-3.5.0-6.fc29.noarch
>    python3-pyflakes-2.0.0-7.fc29.noarch
> 
> Something else must be happening on FreeBSD.

Looks like Fedora is carrying a patch[1] that introduces pyflakes
2.0.0 compatibility, which has been backported from flake8 3.6.0.
I don't expect FreeBSD will backport the patch, they're probably
going to jump straight to the newer upstream release instead.

So we can either merge this patch to make the failures go away for
the time being and re-introduce the job once flake8 3.6.0 is
available in FreeBSD, or endure the failure a bit longer and just
wait for it to go away on its own. In the latter case, re-adding
FreeBSD -CURRENT as a target for the job would make as well.

Let me know which one of the two solutions you prefer.


[1] https://src.fedoraproject.org/rpms/python-flake8/blob/f29/f/python-flake8-3.5.0-pyflakes-2.0.0.patch
-- 
Andrea Bolognani / Red Hat / Virtualization


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]