[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [jenkins-ci PATCH 5/7] Only build osinfo-db-tools on systems with meson >= 0.49.0



osinfo-db-tools has switched its build system to meson and requires
0.49.0 or newer.

Signed-off-by: Fabiano Fidêncio <fidencio redhat com>
---
 guests/host_vars/libvirt-centos-7/main.yml    |  1 -
 guests/host_vars/libvirt-debian-9/main.yml    |  1 -
 guests/host_vars/libvirt-ubuntu-16/main.yml   |  1 -
 guests/host_vars/libvirt-ubuntu-18/main.yml   |  1 -
 .../build/projects/osinfo-db-tools.yml        | 22 ++++++++-----------
 jenkins/projects/osinfo-db-tools.yaml         | 20 ++++++++---------
 6 files changed, 18 insertions(+), 28 deletions(-)

diff --git a/guests/host_vars/libvirt-centos-7/main.yml b/guests/host_vars/libvirt-centos-7/main.yml
index 94e29af..72db363 100644
--- a/guests/host_vars/libvirt-centos-7/main.yml
+++ b/guests/host_vars/libvirt-centos-7/main.yml
@@ -9,7 +9,6 @@ projects:
   - libvirt-perl
   - libvirt-python
   - osinfo-db
-  - osinfo-db-tools
   - virt-viewer
 
 package_format: 'rpm'
diff --git a/guests/host_vars/libvirt-debian-9/main.yml b/guests/host_vars/libvirt-debian-9/main.yml
index 6b685a4..c45c0fb 100644
--- a/guests/host_vars/libvirt-debian-9/main.yml
+++ b/guests/host_vars/libvirt-debian-9/main.yml
@@ -12,7 +12,6 @@ projects:
   - libvirt-sandbox
   - libvirt-tck
   - osinfo-db
-  - osinfo-db-tools
   - virt-manager
   - virt-viewer
 
diff --git a/guests/host_vars/libvirt-ubuntu-16/main.yml b/guests/host_vars/libvirt-ubuntu-16/main.yml
index 179dd03..3e9ae9f 100644
--- a/guests/host_vars/libvirt-ubuntu-16/main.yml
+++ b/guests/host_vars/libvirt-ubuntu-16/main.yml
@@ -12,7 +12,6 @@ projects:
   - libvirt-sandbox
   - libvirt-tck
   - osinfo-db
-  - osinfo-db-tools
   - virt-viewer
 
 package_format: 'deb'
diff --git a/guests/host_vars/libvirt-ubuntu-18/main.yml b/guests/host_vars/libvirt-ubuntu-18/main.yml
index 5b5bf0c..4a38ab0 100644
--- a/guests/host_vars/libvirt-ubuntu-18/main.yml
+++ b/guests/host_vars/libvirt-ubuntu-18/main.yml
@@ -12,7 +12,6 @@ projects:
   - libvirt-sandbox
   - libvirt-tck
   - osinfo-db
-  - osinfo-db-tools
   - virt-manager
   - virt-viewer
 
diff --git a/guests/playbooks/build/projects/osinfo-db-tools.yml b/guests/playbooks/build/projects/osinfo-db-tools.yml
index c5d0281..1e69e0d 100644
--- a/guests/playbooks/build/projects/osinfo-db-tools.yml
+++ b/guests/playbooks/build/projects/osinfo-db-tools.yml
@@ -1,19 +1,9 @@
 ---
 - set_fact:
     name: osinfo-db-tools
-    machines: '{{ all_machines }}'
-    archive_format: gz
-    git_url: '{{ git_urls["osinfo-db-tools"][git_remote] }}'
-
-- include: '{{ playbook_base }}/jobs/prepare.yml'
-- include: '{{ playbook_base }}/jobs/autotools-build-job.yml'
-- include: '{{ playbook_base }}/jobs/autotools-syntax-check-job.yml'
-- include: '{{ playbook_base }}/jobs/autotools-check-job.yml'
-  vars:
-    # osinfo-db-tools tests are Python 3 only, so they can't be ran on
-    # CentOS 7;
+    # osinfo-db-tools depends on meson 0.49.0, which is not available on
+    # CentOS 7, Debian 9, Ubuntu 18;
     machines:
-      - libvirt-debian-9
       - libvirt-debian-10
       - libvirt-debian-sid
       - libvirt-fedora-29
@@ -22,7 +12,13 @@
       - libvirt-freebsd-11
       - libvirt-freebsd-12
       - libvirt-freebsd-current
-      - libvirt-ubuntu-18
+    archive_format: gz
+    git_url: '{{ git_urls["osinfo-db-tools"][git_remote] }}'
+
+- include: '{{ playbook_base }}/jobs/prepare.yml'
+- include: '{{ playbook_base }}/jobs/autotools-build-job.yml'
+- include: '{{ playbook_base }}/jobs/autotools-syntax-check-job.yml'
+- include: '{{ playbook_base }}/jobs/autotools-check-job.yml'
 - include: '{{ playbook_base }}/jobs/autotools-rpm-job.yml'
   vars:
     machines: '{{ rpm_machines }}'
diff --git a/jenkins/projects/osinfo-db-tools.yaml b/jenkins/projects/osinfo-db-tools.yaml
index c75d323..d183e75 100644
--- a/jenkins/projects/osinfo-db-tools.yaml
+++ b/jenkins/projects/osinfo-db-tools.yaml
@@ -1,7 +1,15 @@
 ---
 - project:
     name: osinfo-db-tools
-    machines: '{all_machines}'
+    # osinfo-db-tools requires meson 0.49.0, which is not available on
+    # CentOS 7 and Debian 9;
+    machines:
+      - libvirt-debian-10
+      - libvirt-fedora-29
+      - libvirt-fedora-30
+      - libvirt-fedora-rawhide
+      - libvirt-freebsd-11
+      - libvirt-freebsd-12
     title: osinfo database tools
     archive_format: gz
     git_url: '{git_urls[osinfo-db-tools][default]}'
@@ -12,16 +20,6 @@
           parent_jobs: 'osinfo-db-tools-build'
       - autotools-check-job:
           parent_jobs: 'osinfo-db-tools-syntax-check'
-          # osinfo-db-tools tests are Python 3 only, so they can't be ran on
-          # CentOS 7;
-          machines:
-            - libvirt-debian-9
-            - libvirt-debian-10
-            - libvirt-fedora-29
-            - libvirt-fedora-30
-            - libvirt-fedora-rawhide
-            - libvirt-freebsd-11
-            - libvirt-freebsd-12
       - autotools-rpm-job:
           parent_jobs: 'osinfo-db-tools-check'
           machines: '{rpm_machines}'
-- 
2.21.0


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]