[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt PATCH 037/351] meson: add readline build option



On Wed, Aug 05, 2020 at 02:37:09PM +0200, Pavel Hrdina wrote:
> On Wed, Aug 05, 2020 at 02:00:14PM +0200, Erik Skultety wrote:
> > On Wed, Aug 05, 2020 at 01:47:21PM +0200, Andrea Bolognani wrote:
> > > On Wed, 2020-08-05 at 13:27 +0200, Pavel Hrdina wrote:
> > > > Gross hack in our CI vs gross hack in spec file. I vote for CI to have
> > > > the hack.
> > > > 
> > > > In addition the macros are provided by meson and there are changes in
> > > > the macro file, for example the latest macro file uses `meson compile`
> > > > instead of `ninja build` which was introduced in 0.54.0 so we would have
> > > > to have some older copy of the macros.
> > > 
> > > Not really, since the version of Meson that we use for building would
> > > still be the one installed from PyPi, eg. 0.54.0 or newer. What about
> > > the other way around? Would the old macros work fine with the newer
> > > Meson?
> > 
> > An alternative idea, meson 0.54.0 depends on Python 3.8 ABI. Python 3.8 is
> > available on CentOS-8, so maybe we could try asking for a meson 0.54 build on
> > CentOS 8 as well.
> 
> I don't think that's true. The setup.py file in upstream meson requires
> python 3.5.2 and the README.md file mentions python 3.5. Are you sure
> about that?

Hmm, it's what I got from unpacking the CPIO of the rpm package, but looking at
the specfile of 0.54, it requires python%{python3_version}, which resolves to
3.8 on Fedora but would resolve to 3.6 on CentOS-8, so you're right. The
exact version doesn't really matter, what should matter in the email is the
overall idea to actually try pushing for a more modern meson.

Erik


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]