[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Conflicting parameters on qemu call



Hi Lists,

I currently have the issue of wanting to use emu-system-x86_64 on a ppc64le platform.

It is imperative to pass the "-accel tcg,thread=multi” parameter to qemu when starting an instance, as without that, it will only use one thread and hence of limited/no use.

The problem is, that libvirt itself, passes “-machine q35,accel=tcg” to qemu, which is a different parameter, that conflicts with the other one.

Can we discuss, if I either have overlooked something, or is there a workaround, or is this a bug?

I’m running: 
# uname -a
Linux tiger-v4 5.7.0-1-powerpc64le #1 SMP Debian 5.7.6-1 (2020-06-24) ppc64le GNU/Linux

# apt-cache policy libvirt-daemon
libvirt-daemon:
  Installed: 6.5.0-1
  Candidate: 6.5.0-1
  Version table:
 *** 6.5.0-1 500
        500 http://deb.debian.org/debian testing/main ppc64el Packages

# apt-cache policy qemu-system-x86
qemu-system-x86:
  Installed: 1:5.0-14
  Candidate: 1:5.0-14
  Version table:
 *** 1:5.0-14 500
        500 http://deb.debian.org/debian testing/main ppc64el Packages

Do you need any more information?

Feel free to only continue on the list that matters.

Greetings, Jan



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]