[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [GSoC][PATCH v2] virmigraiton: `qemuMigrationJobPhase` transformed for more generic use



On Wed, Aug 26, 2020 at 11:24:09 +0530, Prathamesh Chavan wrote:
> `qemuMigrationJobPhase` was transformed into `virMigrationJobPhase`
> and a common util file `virmigration` was created to store its
> defination.
> 
> This is one of the initial steps we are taking towards making
> more and more code hypervisor agnostic. And this shall
> be followed by transformation of similar structs in the future.

I'm not really persuaded that this enum makes sense outside of the qemu
hypervisor driver.

If any new hypervisor implements migration it's not very likely to share
the steps required in the qemu driver anyways.

Aditionally making this too universal might lead to a false assumption
that all the phases make sense for a new hypervisor driver implementing
migration.

If you have any more justification for this change please put it into
the commit message.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]