[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt PATCH] wireshark: Don't include config.h



On Fri, 2020-09-04 at 15:30 +0200, Michal Prívozník wrote:
> On 9/4/20 2:21 PM, Andrea Bolognani wrote:
> > On Fri, 2020-09-04 at 11:50 +0200, Michal Prívozník wrote:
> > > The patch looks good. ws_version.h was introduced with 2.9.0 release
> > > which is 1.5 years old. Given that the dissector is aimed mostly on us,
> > > developers to help us debug RPC issues, I think we can safely bump the
> > > minimal wireshark version required (currently 2.4.0 which is 3 years old).
> > 
> > That sounds reasonable in theory, but if you look at
> > 
> >    https://gitlab.com/abologna/libvirt/-/pipelines/185421025
> > 
> > you'll see that even platforms that ship pretty recent Wireshark[1]
> > don't include ws_version.h among the headers.
> > 
> > Not building the dissector on those non-obsolete platforms seems
> > excessively harsh, so I think an approach similar to the one I
> > described above is still necessary. And at that point, you might as
> > well not bump the minimum required version and keep building the
> > dissector on the current list of platforms...
> 
> Any idea why they are not installing the file? Because while current 
> solution is hacky, intentionally removing a header file that a package 
> wants installed is way worse.

I don't think it's done on purpose: it's probably just a bug in the
Debian packaging that got propagated to Ubuntu.

Even assuming that's the case, it will take some time for it to be
addressed in sid, and the first Ubuntu LTS that will carry the
resulting fix is almost two years out... So I think we have to just
support both ws_version.h and config.h for a while.

-- 
Andrea Bolognani / Red Hat / Virtualization


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]