[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] Ruby-libvirt and openAuth



Ignore my last post. I copied what the debian package does for the bindings. All works fine now!

On Wed, Oct 6, 2010 at 1:44 PM, Jonathan Kelley <jkelley vm-labs com> wrote:
Anyone have any luck using libvirt library inside a ruby cgi script?

I am getting load errors (Internal Server Error) on failing to find _libvirt. The same script works fine run from the cmd shell. 

My webserver is lighttpd.

Thanks,
Jon

On Tue, Oct 5, 2010 at 10:08 AM, Chris Lalancette <clalance redhat com> wrote:
On 10/05/10 - 09:58:25AM, Jonathan Kelley wrote:
> I guess I was expecting to find a ruby library making calls into the C
> library like the Python libvirt.py that is generated.
>
> I saw these files and thought I was missing something but I understand now
> the difference between the Ruby and Python bindings.

Ah, no.  The way that this particular binding works is that it is all C code
that bridges between the libvirt C api and the various rb_* routines to hook
it into ruby.  There are other approaches possible, including something
called FFI, but I haven't really looked at them.

I've sent you the RDoc documentation for what is in git in a private email.
Once I do the next release I will post this updated documentation to the
website.

--
Chris Lalancette



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]