[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] live migration without shared storage problems.



于 2011年10月27日 11:16, Luengffy XUE 写道:
Oh, I think I can describe the problem more specific.

1         Creat the vm in the source host and it run well.
2     Create the image in the destination and change the user and group

2)的意思是你自己在dest上创建了同名的image么?

3 Open TCP socket in the destination host.

你是咋作的,这都是libvirt/qemu自己来完成的,dest上qemu会以-incoming
启动。


In the source host I use the different command as

1  $ virsh migrate --live --copy-storage-all vmubuntu qemu+ssh://destinationHost/system --verbose

This situation, the error is:

In the source host:
error:operation failed:migration job:unexpectedly failed
In the destiantion host: (from the vm.log)
qemu:Warning: error while loading State ID section 2

 

2    $ virsh migrate --live --copy-storage-all vmubuntu qemu+ssh://destinationHost/system tcp://destinationHost:49170 --verbose

This situation, the error is:


In the source host:
error: operation failed : failed to retrieve chardev info inqemu with 'info chardev'
In the destiantion host: (from the vm.log)
Migration failed. Exit code tcp:0.0.0.0:49170(-98),exiting.



Can you help me ?  I google the error on the www . But I can not find the proper solutions  or the same questions.

Thanks very much.
Best wishes.


2011/10/27 Osier Yang <jyang redhat com>
于 2011年10月26日 22:22, Luengffy XUE 写道:
Hi, all
I migrate a vm from source host to the destination host. 
I am sure every part is ok for migration.
1   Create the  image in the destination and change the user and group.
2   Open TCP socket in the destination host. 
and I migrate in the source host command line.   
$ virsh migrate --live --copy-storage-all vmubuntu  qemu+ssh://destinationHost/system --verbose
But I get the  error
"error: operation failed : failed to retrieve chardev info inqemu with 'info chardev'" 

Looks like you even failed on starting the domain. Could you confirm if you
guest is actually running well?

In the destination I find in the vmubuntu.log  
The error is 
"Migration failed. Exit code tcp:0.0.0.0:49170(-98),exiting."

What can I do to solve it ? 
I do not understand how the error comes.
Anyone can help me ?
Thanks in advance. 





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]