[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] serial console with virt-install



On 2012年02月08日 05:08, Felix Blanke wrote:
Hello,

sorry for bother you again. I'm new to kvm and libvirt, that's why my
next question is maybe some sort of noob question :)

I have a headless server (no X at all, just ssh) and want to run some
virtual machines on it. I have kvm etc. all set up.

When doing something like

virt-install --connect qemu:///system -n template -r 1024 --disk
path=/data/vm/template.qcow2,format=qcow2 -c
/data/vm/livedvd-amd64-multilib-2012.iso --os-type linux -v
--network=bridge:br0 --virt-type kvm --arch x86_64 --graphics none


the vm starts

Starting install...
Creating domain...

Connected to domain template
Escape character is ^]


That's it, no more output. I see two threads running, each takes up 100%
cpu.
I tried to help myself via google and read a lot hints like "you need to
setup your guest to get a serial console...", but that's not possible
when running a fresh vm. All I want to do is getting some sort of
console from the vm to start the installation with the given .iso file.

Could someone lead me into the right direct? A link to an explanation
would be more then enough :)

Try "--extra-args" to see if it works for you. e.g.

--extra-args="console=ttyS0,115200"

Thanks for your help.



Kind regards,
Felix Blanke

_______________________________________________
libvirt-users mailing list
libvirt-users redhat com
https://www.redhat.com/mailman/listinfo/libvirt-users


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]