[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] error: argument unsupported: unable to handle disk requests in snapshot



> Hello, a problem occurred during making a snapshot for a guest, ask
> for help...
> 
> 1. the xml for snapshotdomain like this:
> # cat deployment.1
> <domainsnapshot>
>    <name>a</name>
>    <disks>
>     <disk name='/home/qcow2/disk.0'>
>       <driver type='qcow2'/>
>       <source file='/home/qcow2/disk.3'/>
>     </disk>

This says that you want to create an external snapshot...

>   </disks>
> </domainsnapshot>
> 
> 2. when i execute the command , a mistake occurred:
> # virsh snapshot-create qcow2 deployment.1

But this did not request the --disk-only flag, and was not executed
with (unreleased) libvirt 1.0.1.  Older libvirt doesn't support
external snapshots without the --disk-only flag (but the next
release will; assuming that you have new enough qemu).

> error: argument unsupported: unable to handle disk requests in
> snapshot
> 
> 3. i add the parameter '--disk-only', another mistake occurred:
> # virsh snapshot-create qcow2 deployment.1 --disk-only
> error: Failed to take snapshot: unknown command: 'snapshot_blkdev'

This says your qemu is too old.  External snapshots were not possible
until upstream qemu 1.2; it is also available if you use RHEV 3.0
from Red Hat (but NOT if you use RHEL 6.3).

> is there anyone has the same problem with me ?

Yes, since you are trying code that hasn't been implemented
for the versions of software you have installed.

> Confidentiality Notice: The information contained in this e-mail and

This disclaimer is unenforceable on a publicly-archived list.
For netiquette reasons, it is considered better to send mail from
a personal account so as to avoid your employer's useless
legalese when posting to public lists.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]