[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt-users] gentoo linux, problem starting vm ´s when cache=none




hello mailinglist,

on gentoo system with qemu-1.6.1, libvirt 1.1.4, libvirt-glib-0.1.7, virt-manager 0.10.0-r1

when i set on virtual machine "cache=none" in the disk-menu, the machine faults to start with:

<<
Fehler beim Starten der Domain: Interner Fehler: Prozess während der Verbindungsaufnahme zum Monitor beendet :qemu-system-x86_64: -drive file=/raid6/virtual/debian-kaspersky.img,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,aio=native: could not open disk image /raid6/virtual/debian-kaspersky.img: Invalid argument


Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/asyncjob.py", line 100, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
File "/usr/share/virt-manager/virtManager/asyncjob.py", line 122, in tmpcb
    callback(*args, **kwargs)
File "/usr/share/virt-manager/virtManager/domain.py", line 1210, in startup
    self._backend.create()
File "/usr/lib64/python2.7/site-packages/libvirt.py", line 708, in create if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self) libvirtError: Interner Fehler: Prozess während der Verbindungsaufnahme zum Monitor beendet :qemu-system-x86_64: -drive file=/raid6/virtual/debian-kaspersky.img,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,aio=native: could not open disk image /raid6/virtual/debian-kaspersky.img: Invalid argument


when i switch back to cache=default, the machine start like a charm.

any ideas why? i cant find anything in logs, only this "invalid argument".

the machine is created with profile "linux / debian squeeze" cause its a debian 6

marko


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]