[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt-users] vlan tagging for openVSwitch



hi everyone,

I'm trying to get vlans tagged in libvirt as my switch's end (yes
traffic will be leaving the host and into network switches) allows only
tagged vlans.

But with network as such:

...

  <portgroup name='vlan-55'>
    <vlan trunk='yes'>
      <tag id='55'/>
    </vlan>
  </portgroup>
</network>

and guest as:

    <interface type='network'>
      <mac address='52:54:00:15:00:26'/>
      <source network='ovsbr0' portgroup='vlan-55'/>
      <model type='virtio'/>
    </interface>

When the guest is fully initialized vSwitch shows: 

...

_uuid               : b3c130db-fa84-49f8-9cf5-824ec8cf3b81
bond_downdelay      : 0
bond_fake_iface     : false
bond_mode           : []
bond_updelay        : 0
external_ids        : {}
fake_bridge         : false
interfaces          : [35c0a914-a21a-43d7-9f63-adacffbb62bc]
lacp                : []
mac                 : []
name                : "ovsbr0"
other_config        : {}
qos                 : []
statistics          : {}
status              : {}
tag                 : []
trunks              : []
vlan_mode           : []

No tags, no trunks, no vlan mode???

Is there something I missed (in docs though I sroogled exensively) ?

I also tried to add mode='trunk' into <tag id='55'/> and virsh does not
complains but next time I edit the guest the mode bit is gone.

My vSwitch's bridge has only one phys iface (into the net switch) and I
tried setting that iface with tag/no tag, with vlan_mode/no vlan_mode
but if guest is up with above libvirt's vSwitch initialization then
guest cannot ping net switch no matter the setting for phys iface.

I'm on Centos 7.6 with libvirt-4.5.0-10.el7_6.4.x86_64 &
openvswitch-2.0.0-7.el7.x86_64.

What can be the problem here?

many thanks, L.






Attachment: pEpkey.asc
Description: application/pgp-keys


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]