[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] vlan tagging for openVSwitch



On 3/13/19 6:52 AM, lejeczek wrote:
hi everyone,

I'm trying to get vlans tagged in libvirt as my switch's end (yes
traffic will be leaving the host and into network switches) allows only
tagged vlans.

But with network as such:

...

   <portgroup name='vlan-55'>
     <vlan trunk='yes'>


I responded to the bug you filed at bugzilla.redhat.com, but I'll respond here too in case someone comes across this message in the future.

If you want untagged traffic from the guest to be tagged as it is going onto the OVS switch, then you do not want "trunk='yes'" here. Either set trunk='no', or just leave it out.

If you set trunk='yes' then (as I understand it) traffic tagged with id 55 will be allowed through the port, but the tag won't be removed or added. in either direction.


       <tag id='55'/>
     </vlan>
   </portgroup>
</network>

and guest as:

     <interface type='network'>
       <mac address='52:54:00:15:00:26'/>
       <source network='ovsbr0' portgroup='vlan-55'/>
       <model type='virtio'/>
     </interface>

When the guest is fully initialized vSwitch shows:

...

_uuid               : b3c130db-fa84-49f8-9cf5-824ec8cf3b81
bond_downdelay      : 0
bond_fake_iface     : false
bond_mode           : []
bond_updelay        : 0
external_ids        : {}
fake_bridge         : false
interfaces          : [35c0a914-a21a-43d7-9f63-adacffbb62bc]
lacp                : []
mac                 : []
name                : "ovsbr0"
other_config        : {}
qos                 : []
statistics          : {}
status              : {}
tag                 : []
trunks              : []
vlan_mode           : []

No tags, no trunks, no vlan mode???

Is there something I missed (in docs though I sroogled exensively) ?

I also tried to add mode='trunk' into <tag id='55'/> and virsh does not
complains but next time I edit the guest the mode bit is gone.

There is no such attribute "mode='trunk'". The accepted attributes for the <vlan> attribute can be found at https://libvirt.org/formatnetwork.html - search for "vlan" within that page.


My vSwitch's bridge has only one phys iface (into the net switch) and I
tried setting that iface with tag/no tag, with vlan_mode/no vlan_mode
but if guest is up with above libvirt's vSwitch initialization then
guest cannot ping net switch no matter the setting for phys iface.

I'm on Centos 7.6 with libvirt-4.5.0-10.el7_6.4.x86_64 &
openvswitch-2.0.0-7.el7.x86_64.

What can be the problem here?

many thanks, L.







_______________________________________________
libvirt-users mailing list
libvirt-users redhat com
https://www.redhat.com/mailman/listinfo/libvirt-users



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]