[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Linux audit for Debian



Hi Grubb,

BTW, Is there any restriction about the version of kernel headers?

I have changed to headers of kernel 2.6.15.3, but errors keeps happening.

What is the version of kernel headers do you recommend?

BR,

Mauricio Lin.

On 2/21/06, Steve Grubb <sgrubb redhat com> wrote:
On Tuesday 21 February 2006 11:09, Mauricio Lin wrote:
> > > In file included from /usr/include/linux/sched.h:12,
> > > from /usr/include/linux/audit.h:27,
> > > from libaudit.h:35,
> > >/usr/include/linux/jiffies.h:84: error: syntax error before 'jiffies_64'
> > >/usr/include/linux/jiffies.h:88: error: syntax error before
> >
> > 'get_jiffies_64'
> >
> > Sounds like a problem in the kernel headers. Probably a missing include.
>
> Do you mean the jiffies.h or sched.h or audit.h is missing an include?

jiffies.h is where all the errors are, so its the one that is probably missing
the include. I have no idea what include it needs, but it seems to be
something that defines a common type.

-Steve


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]