[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [PATCH] new audit rule interface



On Friday 06 January 2006 10:30, Debora Velarde wrote:
> > 
> > Of the three, I prefer audit_rule_transport, but it seems
> > unnecessarily long to me.  I suppose we could shorten it to
> > audit_rule_trans, but I'm not sure that's any more readable than
> > 'xprt'.
> > 
> > What do you think about changing the comment to make it more
> > descriptive?  i.e.,
> > 
> > /* audit_rule_xprt is used to transport audit filter rule content
> >  * between kernel and userspace.  It supports filter rules with both
> >  * integer and string fields and corresponds with AUDIT_ADD_RULE,
> >  * AUDIT_DEL_RULE and AUDIT_LIST_RULES requests.
> >  */
> > 
> > Amy
> 
> IMHO changing audit_rule_xprt to audit_rule_transport does make it more 
> readable.
> But then does that also mean changing all occurrences of 'xprt' to 
> 'transport' for consistency?
> i.e. 
> xprt->buf becomes transport->buf
> audit_krule_to_xprt() becomes audit_krule_to_transport()
> 
> Not sure that changing one and leaving the others 'xprt' really helps the 
> overall readability.

Good points Debbie.  And just to add fuel to the fire, if we're concerned about
verbosity and readability, why not just:
 
audit_transport

-tim


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]