[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [PATCH] new audit rule interface



On Fri, Jan 06, 2006 at 01:58:29PM -0600, Dustin Kirkland wrote:
> On Fri, 2006-01-06 at 11:10 -0600, Timothy R. Chavez wrote:
> > Good points Debbie.  And just to add fuel to the fire, if we're
> > concerned about verbosity and readability, why not just:
> >  
> > audit_transport
> 
> I think that unfortunately looses the fact that this is a data structure
> representing an "audit rule".

That's true.

The more I think about it, I don't really like xprt/transport.
Looking through the kernel sources, the only code that uses xprt
meaning transport is RPC code.  I'd prefer to avoid any unwarranted
associations with RPC.  I also don't think transport accurately
describes what's happening here.

How about audit_rule_data?  I would personally prefer that to
audit_rule_xprt.

Amy


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]