[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Compile Error



On Thursday 17 December 2009 01:22:52 am 陈洁丹 wrote:
> I search the Internet , but  there is no solution.
> Do I need to add other library? which one?

>From the download page, you need kernel headers >= 2.6.30. There was a lot of 
ancient code in upstream kernels that I did not want to continue distributing 
so that the headers could be cleaned up. Also, because the API changed, that 
means it has a soname number change, which means you will need to recompile 
everything that links with libaudit. So, it would only be needed for new linux 
distributions, which should be using a recent kernel.

If you have an older distribution and kernel, use 1.7.17 instead. Fedora 11, 
for example, uses it. But since Fedora 12 is new, it uses the 2.0.x series.

-Steve


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]