[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Re: Error compiling GFS patched kernel



Jens Dreger <jens dreger physik fu-berlin de> writes:

> On Mon, Aug 30, 2004 at 05:30:29PM -0400, Ed L Cashin wrote:
>> "Angelo Ovidi" <angel telvia it> writes:
>> 
>> >    Hi.
>> >
>> >    I am trying to compile a 2.6.7 kernel patched with cvs version of
>> >    cluster package of redhat.
>> >
>> >    I have no error applying the patches but the compile give me this
>> >    error:
>> 
>> I get the same error using the "Method 2: using kernel patches"
>> procedure from http://sources.redhat.com/cluster/doc/usage.txt
>> with this tarball:
>> 
>>   cluster_0406282100.tgz
>
> Try upgrading gcc. I got that error with gcc 2.95. Upgrading to gcc >3
> solved the problem.

Thanks.  Yes, I noticed that it works with gcc 3.3, but the snapshot
has been up for a while, and it doesn't work with gcc 2, so it seems
like gcc 2 is not supported by gfs, which merits a big warning in any
usage.txt-type docs.

-- 
  Ed L Cashin <ecashin coraid com>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]