[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] unresolved symbol



On Mon, 2004-07-19 at 04:09, chloong wrote:
> hi all,
> I am facing this unresolved symbol error when i do a depmod -a for gfs.
> 
> i am using kernel 2.4.21-15.0.3.EL. I actually re-compile the GFS using 
> GFS-6.0.0-1.2.src.rpm from HughesJR.com where it is able to compile 
> under 2.4.21-15.0.3.EL version where as the one that i downloaded from 
> RedHat is only be able to compile under 2.4.21-15.EL version.
> 
> I was able to compile it and installed but when i run depmod -a it 
> complain that there are unresolved symbol for all the GFS modules....

Did you compile the version for your arch (i686, athlon)?

If you are running a i686 kernel, you need to compile with a target=i686
or if you have an athlon kernel, you need to compile with target=athlon

You can download the binary modules from my site as well and see if you
have the same problem.

In order to compile the SRPM as written for a target=athlon you will
need to install (at least for the compile), kernel-unsupported,
kernel-smp, and kernel-source ... for target=i686 you need to install 
kernel-unsupported, kernel-smp, kernel-source, and kernel-hugemem

Johnny Hughes
HughesJR.com

> I checked that my kernel version is correct using uname -r...
> 
> How could i go about this....? Please help....




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]