[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] unresolved symbol solved!



Jonny,
Thanks a lot man!

I managed to install GFS and run it. Actually i used back the kernel-2.4.21-15.EL for smp. As follow what you said, installed all kernel-source, kernel-hugemem, kernel-unsupported, kernel-smp and then recompile from src. Now no more unresolved symbol and able to modprobe all the modules.

Need to configure GFS now.

Thanks again man!


Johnny Hughes wrote:
On Mon, 2004-07-19 at 05:21, chloong wrote:
  
hi Johnny,
I  had tried using your bin, both i386 & i686, but still have the same 
problem.
BTW, how could i know what target should i use? i am running on a x86 
platform and i compile the kernel myself and i select the cpu type as 
386 family with no smp support.

the kernel source i downloaded from rpmfind. The version is 
kernel-2.4.21-15.0.3.EL.src.rpm. I used back the kernel config file 
provided from this rpm and changed it to no smp support.

    
OK, did you build a kernel rpm and install it ... if so, what was the
name of the kernel's rpm.

Is this on RHEL or a clone like WBEL/CentOS/TaoLinux?

  
Everything are fine after reboot using this kernel. Then i compile the 
gfs source from your side. The compilation was successful. After 
installation, when i do a depmod -a, it still gave me unresolved symbol 
for gfs modules....

    
I installed:
GFS-6.0.0-1.2.i686.rpm
GFS-devel-6.0.0-1.2.i686.rpm
GFS-modules-6.0.0-1.2.i686.rpm
perl-Net-Telnet-3.03-2.noarch.rpm

Then do a:

depmod -a

No errors...

Johnny Hughes
HughesJR.com




  


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]