[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] WARNING: libdlm kernel interface change in CVS



I have just checked in a change that breaks backwards compatibility with
libdlm and the dlm kernel.

If you update the kernel from CVS you /must/ also update libdlm. And,
conversely, don't ugrade libdlm on its own unless you are also changing the
kernel.

If you get odd errors from userland programs that use the DLM then check that
both libdlm and the kernel.

If applications are linked against the shared libdlm then it will be sufficient
to upgrade the libdlm.so file only, the library ABI has not changed.

Sorry for the inconvenience.
-- 

patrick


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]