[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] problem with fencing



On Aug/05/2005, Adam Manthei wrote:

> > could anybody give me a hint?
> how about this?  looks like there is a typo in you cluster.conf
> > gfstest1:~# fence_IBMswitch -a 10.1.1.1 -l admin -p tangerine -n 4 -o enable
>               ^^^^^^^^^^^^^^^
> >           <fencedevice name="san" agent="fence_IBM" ipaddr="10.1.1.1" 
>                                            ^^^^^^^^^

yipes ... that was a big and stupid mistake :/
thanks for helping me see it (i've spent lot of time today trying to
debug this ... sigh)

anyway, now I cannot seem to even join the fence cluster with the
machine I'm doing the testing and so ..:

gfstest2:~# fence_tool -w -D join
fence_tool: wait for quorum 1
fence_tool: get our node name
fence_tool: connect to ccs
fence_tool: start fenced
fenced: 1123256223 our name from cman "gfstest2"
fenced: 1123256223 delay post_join 6s post_fail 0s
fenced: 1123256223 added 3 nodes from ccs
^C
gfstest2:~# fence_tool -w -D -c join
fence_tool: wait for quorum 1
fence_tool: get our node name
fence_tool: connect to ccs
fence_tool: start fenced
fenced: 1123256379 our name from cman "gfstest2"
fenced: 1123256379 delay post_join 6s post_fail 0s
fenced: 1123256379 clean start, skipping initial nodes
fenced: fence_domain_add: service set level failed
gfstest2:~# cman_tool services
Service          Name                              GID LID State     Code
Fence Domain:    "default"                           0   2 join      S-1,80,3
[]

gfstest2:~# 

I maybe leave it for monday, as today I'm having a pretty bad day :/

-- 
Javier Polo @ Datagrama
902 136 126


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]