[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Problems while installing the Heartbeat 2.0.0 on a RH AS 3.0 Update 5



Good Afternoon,

I'm trying to install the Heartbeat 2.0.0 package to create a High
Availability solution.

I have two IBM XSeries x455 using Red Hat Advanced Server 3 Update 5 here.

I've downloaded the following files from the linux-ha.org official
download home page:
- heartbeat-2.0.0-1.x86_64.rpm
- heartbeat-pils-2.0.0-1.x86_64.rpm
- heartbeat-stonith-2.0.0-1.x86_64.rpm

While trying to install them using rpm -ivh *, I receive the following
errors (dependencies):

[root svdb2-1 RPMS]# rpm -ivh * > /root/dependencies-heartbeat.log
error: Failed dependencies:
        libc.so.6()(64bit) is needed by heartbeat-2.0.0-1
        libc.so.6(GLIBC_2.2.5)(64bit) is needed by heartbeat-2.0.0-1
        libc.so.6(GLIBC_2.3)(64bit) is needed by heartbeat-2.0.0-1
        libm.so.6()(64bit) is needed by heartbeat-2.0.0-1
        libnet.so.0()(64bit) is needed by heartbeat-2.0.0-1
        libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by heartbeat-2.0.0-1
        libc.so.6()(64bit) is needed by heartbeat-pils-2.0.0-1
        libc.so.6(GLIBC_2.2.5)(64bit) is needed by heartbeat-pils-2.0.0-1
        libcrypto.so.0.9.7()(64bit) is needed by heartbeat-stonith-2.0.0-1
        libc.so.6()(64bit) is needed by heartbeat-stonith-2.0.0-1
        libc.so.6(GLIBC_2.2.5)(64bit) is needed by heartbeat-stonith-2.0.0-1
        libc.so.6(GLIBC_2.3)(64bit) is needed by heartbeat-stonith-2.0.0-1


I checked using a #rpm -qa | grep -i glibc and I have the following
files already installed:

glibc-kernheaders-2.4-8.34.1
glibc-2.3.2-95.33
glibc-headers-2.3.2-95.33
glibc-common-2.3.2-95.33
glibc-2.3.2-95.33
glibc-profile-2.3.2-95.33
glibc-devel-2.3.2-95.33
glibc-utils-2.3.2-95.33


I checked which of the files above are missing using the following command:

[root svdb2-1 logs-glibc-fabio]# rpm -q --provides glibc | grep -i libc.so.6
libc.so.6  
libc.so.6(GCC_3.0)  
libc.so.6(GLIBC_2.0)  
libc.so.6(GLIBC_2.1)  
libc.so.6(GLIBC_2.1.1)  
libc.so.6(GLIBC_2.1.2)  
libc.so.6(GLIBC_2.1.3)  
libc.so.6(GLIBC_2.2)  
libc.so.6(GLIBC_2.2.1)  
libc.so.6(GLIBC_2.2.2)  
libc.so.6(GLIBC_2.2.3)  
libc.so.6(GLIBC_2.2.4)  
libc.so.6(GLIBC_2.2.6)  
libc.so.6(GLIBC_2.3)  
libc.so.6(GLIBC_2.3.2)  
libc.so.6(GLIBC_2.3.3)  
libc.so.6.1()(64bit)  
libc.so.6.1(GLIBC_2.2)(64bit)  
libc.so.6.1(GLIBC_2.2.1)(64bit)  
libc.so.6.1(GLIBC_2.2.2)(64bit)  
libc.so.6.1(GLIBC_2.2.3)(64bit)  
libc.so.6.1(GLIBC_2.2.4)(64bit)  
libc.so.6.1(GLIBC_2.2.6)(64bit)  
libc.so.6.1(GLIBC_2.3)(64bit)  
libc.so.6.1(GLIBC_2.3.2)(64bit)  
libc.so.6.1(GLIBC_2.3.3)(64bit)  

Do someone has ever encountered that problem? Which package can I
install to solve all the dependencies?

Thanks a Lot!!
-- 
Fábio Augusto Miranda Martins
E-mail: fabiomirmar gmail com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]