[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] two fencing problems



two (probably related) questions concerning fencing and APC AP7900 units:

1) fence_apc doesn't appear to be compatible with these units - when I run:

sudo /sbin/fence_apc -a <ipaddy> -l <usr> -p <pwd> -n1 -T -v

it comes back with:

failed: unrecognised menu response

The output file shows that it's getting as far as the "Outlet Control/Configuration" menu, but never selects the specified port.

This is on RHEL ES4 update 2 with fence-1.32.6-0 installed.

Does anyone have this working with AP7900s, and if so did you have to hack the fence_apc script or is there just something I'm missing?

2) in the cluster configuration tool (GUI), there's no place to specify the port to cycle for an "APC Power Device". I tried adding "port=#" to the <fencedevice ...> tags in the cluster.conf file, but the cluster configuration tool didn't like that. And of course, I was unable to test if this actually works anyway because of problem #1 :-(

Anyway, assuming I get fence_apc to work, how do I specify ports in the cluster configuration tool? or is this not supported? In which case can I add the port option in the cluster.conf like I'm trying to do and have it work? I have system-config-cluster-1.0.16-1.0 installed.

-g

Greg Forte
gforte udel edu
IT - User Services
University of Delaware
302-831-1982
Newark, DE


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]