[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] manual fencing not working in RHEL4 branch



On Thu, Dec 08, 2005 at 11:19:38AM -0700, busy admin wrote:
> David,
> 
> We are using cluster-1.00 code.  I didn't see modifications under 1.01
> that would have an impact, but maybe I missed something.
> 
> You are right, I see step 5 happen before step 4 (but remember,
> sometimes it works fine specially after I run with 'fenced -D').  And
> I have never seen any of these problems when I use IPMI or DRAC.
> 
> BTW, for simplicity sake, I wasn't even running rgmanager.  Just ccsd,
> cman and fenced.

Then I'm confused; I thought we defined the problem as step 5 (services
starting on A) happening before step 4 (admin running fence_ack_manual).
With no step 5, what's the problem?


> On 12/8/05, David Teigland <teigland redhat com> wrote:
> > On Mon, Dec 05, 2005 at 07:04:38PM -0700, busy admin wrote:
> > > What is the problem:
> > > When running manual fencing and doing failover testing, my secondary
> > > node takes over the service without waiting for a fence_ack_manual.
> > > This all works perfectly with automatic fencing (ipmi, drac).
> >
> > We're going to try this here.  Just to be clear, we expect:
> >
> > 1. A and B in cluster, in fence domain and running rgmanager
> > 2. kill B
> > 3. A should start fence_manual and print message in /var/log/messages
> > 4. admin should run fence_ack_manual on A
> > 5. services from B should fail over to A
> >
> > The problem is you're seeing 5 happen before 4.  What version of the
> > code are you using (cluster-1.01.00 ?)
> >
> > Thanks
> > Dave
> >
> >


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]