[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] ccs_tool ld error on latest cvs



I tried compile the latest cvs tree against 2.6.10 and hit this
loader error.   I'm compiling on redhat 9.

Any ideas?

make[2]: Entering directory `/Views/redhat-cluster/cluster/ccs/ccs_tool'
gcc -Wall -I. -I../config -I../include -I../lib -Wall -O2 -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE `xml2-config --cflags` -DCCS_RELEASE_NAME=\"DEVEL.1106267706\" -I. -I../config -I../include -I../lib -o ccs_tool ccs_tool.c update.c upgrade.c old_parser.c -L../lib `xml2-config --libs` -L/Views/redhat-cluster/cluster/build/lib -lccs -lmagma -lmagmamsg -ldl
/usr/lib/libmagma.so: undefined reference to `pthread_rwlock_rdlock'
/usr/lib/libmagma.so: undefined reference to `pthread_rwlock_unlock'
/usr/lib/libmagma.so: undefined reference to `pthread_rwlock_wrlock'
collect2: ld returned 1 exit status
make[2]: *** [ccs_tool] Error 1

Daniel



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]