[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] kernel versions and gfs



Hi everybody

I have a strange problem. I need to work with some software that refuses
to work under a version of the  kernel > 2.6.8. On the other hand I would 
like to install gfs and all the other related stuff. I used the last 
version from the cvs and it compiles well under kernel 2.6.10 but I cannot
compile it under the 2.6.8 kernel. 

Something like

/home/jaime/clu/cluster-2.6.8.1/gfs-kernel/src/gfs/ops_file.c:1670: error: 
unknown field `flock' specified in initializer
/home/jaime/clu/cluster-2.6.8.1/gfs-kernel/src/gfs/ops_file.c:1670: 
warning: initialization from incompatible pointer type
make[5]: *** 
[/home/jaime/clu/cluster-2.6.8.1/gfs-kernel/src/gfs/ops_file.o] Error 1
make[4]: *** [_module_/home/jaime/clu/cluster-2.6.8.1/gfs-kernel/src/gfs] 
Error 2

Do I need a specific version of gfs for the 2.6.8 version of the kernel?

Thanks 
-- 

           Jaime D. Perea Duarte. <jaime at iaa dot es>
             Linux registered user #10472

           Dep. Astrofisica Extragalactica.
           Instituto de Astrofisica de Andalucia (CSIC)
           Apdo. 3004, 18080 Granada, Spain. 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]