[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] NFS exports disappeared



I currently have a situation on my FC4 system where all exports for one of the file systems disappeared.

Other file systems using the same nfsclient entries are still there, but I have not yet checked that all entries are there for all file systems. The one file system that had lost all exports was so obvious I spent my time trying to debug that one.

I tried bumping up the version number of cluster.conf and ran ccs_tool update with no messages that look like errors, but still no exports. I tried killing the clurmtabd process for that file system and kill -HUP clurgmgrd. It restarted the process, but still no exports. I then removed two nfsclient lines, bumped up the version, ran ccs_tool, restored the missing lines, bumped up the version and ran ccs_tool again. Now those two exports are back, but there others for that file system are still missing.

One client had the file system mounted and had stale NFS handles. After the above procedure the file system was ok without any remount, so that is good.

How can I find all info needed to debug this? What do you want?



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]