[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] installing GFS



Hi,
I am trying to install GFS on 3 cluster nodes with redhat linux-2.6.9-5EL using gnbd. I met with some problems the mount, which says
"# mount -t gfs /dev/gnbd0 /mnt/gfs/ mount: Connection refused"


I have tried the installation with different order and configuration all end up with this error, hope sb can help solve this puzzle. Here are some step I have taken:
1.Insert gfs-lock and gfs kernel modules at the GFS node.
Insert gnbd module at GFS node
2. run gnbd_serv -n at GNBD server;
./gnbd_export -d /dev/hda8 -e mygnbd -c
3. ./gnbd_import -i k35-as4 -n at GFS node
4. Now I want to create logic volume at GFS node: it failed saying
[root k32-as4 sbin]# pvcreate /dev/gnbd0
Device /dev/gnbd0 not found.


So I choose to do the logic volume stuff at the GNBD server side and gfs_mkfs at the GFS side, it succeeded. But it fails again when mounting.
Then I tried to mkfs at GNBD server and mount directly through gnbd device, same error again.


So I am wondering what should be the correct configuration trick.

Thanks for reading this far!







[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]