[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] cman_tool: Can't find broadcast address for node



Hi there,
I'm trying to set up a cluster here, to use gnbd. I downloaded the source from cvs (May 4), branch RHEL4. After a few tweaks compiled succesfully, and I have all the modules loaded
modprobe gfs
modprobe lock_dlm


I start ccsd with no problems. ccsd_test connect does not work. I do not despair and proceed to do cman_tool join -c cluster1 (my cluster.conf is based on the simple example out there, adapted for three machines; transcribed below). This works on one of my three nodes (toshiba, a SuSE 9.2 box). However, on both the other nodes (Debian Sarge's) cman_tool fails:
cman_tool: Can't find broadcast address for node xxx


All machines run latest kernel 2.6.11, through the respective distribution packages. The debian machines can also boot into xen, using kernel 2.6.11, and it doesn't work there either.

Any pointers? don't really know what other information may be useful, so please ask at will and I'll cut&paste.
Thanks a lot


Andres

<?xml version="1.0"?>
<cluster name="cluster1" config_version="1">

 <cman>
 </cman>

 <clusternodes>
   <clusternode name="toshiba" votes="1">
     <fence>
       <method name="single">
         <device name="human" ipaddr="192.168.70.11"/>
       </method>
     </fence>
   </clusternode>
   <clusternode name="debian" votes="1">
     <fence>
       <method name="single">
         <device name="human" ipaddr="192.168.70.44"/>
       </method>
     </fence>
   </clusternode>
   <clusternode name="simmons" votes="1">
     <fence>
       <method name="single">
         <device name="human" ipaddr="192.168.70.112"/>
       </method>
     </fence>
   </clusternode>
 </clusternodes>

 <fence_devices>
   <fence_device name="human" agent="fence_manual"/>
 </fence_devices>

</cluster>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]