[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] RHSCv4 2-node cluster hangs while starting fenced



Title: RHSCv4 2-node cluster hangs while starting fenced

Dear All,

We are setting up a 2 node cluster (node1 and node2) with RHCSv4 with RHELv4 for one of my clients. My hardware is 2 HPDL380 with iLO as a fence device for each node. MSA500 is shared storage for both nodes.

Cluster rpms are installed successfully with latest kernel and RHCS updates from the RHN. Initially all the services (ccsd,cman,fenced etc.) are starting smoothly. The issue is when we unplugged the network cable of node1 and node2 will fencing the node1 and shutdown the machine; then node1 will automatically get shutdown itself. Now both nodes are down. So we start one node (say node1) and it hangs on the fencing domain state when we start the other node (say node2), node2 will shutdown node1 then again node2 shutdown itself. It is very difficult to get the clear picture of these states, since I couldn’t get an idea or how to configure iLO fence device on both nodes.

Please advice how to configure HP iLOs on both nodes and how to rectify this issue.

Here is my cluster.conf:

<?xml version="1.0"?>

<cluster config_version="17" name="alpha_cluster">

        <fence_daemon clean_start="0" post_fail_delay="0" post_join_delay="3"/>

        <clusternodes>

                <clusternode name="node1" votes="1">

                        <fence>

                                <method name="1">

                                        <device name="HPiLO_node2"/>

                                </method>

                        </fence>

                </clusternode>

                <clusternode name="node2" votes="1">

                        <fence>

                                <method name="1">

                                        <device name="HPiLO_node1"/>

                                </method>

                        </fence>

                </clusternode>

        </clusternodes>

        <cman expected_votes="1" two_node="1"/>

        <fencedevices>

                <fencedevice agent="fence_ilo" hostname="10.10.10.1" login="Administrator" name="HPiLO_node1" passwd="RWE232WE"/>

                <fencedevice agent="fence_ilo" hostname="10.10.10.2" login="Administrator" name="HPiLO_node2" passwd="QWD31D4D"/>

        </fencedevices>




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]