[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] RHSCv4 2-node cluster hangs while starting fenced



You can configure HP iLOs from server BIOS ( press [F8] on
server startup). It's for virtual server power manage, virtual local
console manage only. Any local server OS can't see iLO as network device.
iLO work as 'http://<iLO-TCP/IP>'.
You can access iLO server from network workstation from MS Internet
Explorer as 'http://<iLO-TCP/IP>'. For examlpe, in you local network,
http://192.168.31.1

I think that you can't use iLO port for server network and cluster.


Tuesday, November 1, 2005, 9:46:07 AM, you wrote:

HW> Dear All,

HW> We are setting up a2 nodecluster(node1 and node2)withRHCSv4
HW> with RHELv4 for one of my clients. My hardware is 2 HPDL380 with
HW> iLO as a fence device for each node. MSA500 is shared storage for
HW> both nodes.

HW> Cluster rpms are installedsuccessfullywith latestkerneland
HW> RHCS updates from the RHN.Initially all the services
HW> (ccsd,cman,fenced etc.) are starting smoothly.Theissueis when
HW> weunplugged the network cable ofnode1 and node2 will fencing the
HW> node1 and shutdown the machine; then node1 will automatically
HW> getshutdown itself. Now both nodes are down. So we start one node
HW> (say node1) and ithangson the fencing domainstate–when we start
HW> the other node (say node2), node2 will shutdown node1 then again
HW> node2 shutdownitself. It is verydifficult to get the clearpicture
HW> of thesestates, sinceIcouldn’tget an idea or how to configure iLO
HW> fence device on both nodes.

HW> Please advice howto configure HP iLOs on both nodes and how to rectify this issue.

HW> Here is mycluster.conf:

HW> <?xml version="1.0"?>

HW> <cluster config_version="17" name="alpha_cluster">

HW>         <fence_daemon clean_start="0" post_fail_delay="0" post_join_delay="3"/>

HW>         <clusternodes>

HW>                 <clusternode name="node1" votes="1">

HW>                         <fence>

HW>                                 <method name="1">

HW>                                         <device name="HPiLO_node2"/>

HW>                                 </method>

HW>                         </fence>

HW>                 </clusternode>

HW>                 <clusternode name="node2" votes="1">

HW>                         <fence>

HW>                                 <method name="1">

HW>                                         <device name="HPiLO_node1"/>

HW>                                 </method>

HW>                         </fence>

HW>                 </clusternode>

HW>         </clusternodes>

HW>         <cman expected_votes="1" two_node="1"/>

HW>         <fencedevices>

HW>                 <fencedevice agent="fence_ilo"
HW> hostname="10.10.10.1" login="Administrator" name="HPiLO_node1"
HW> passwd="RWE232WE"/>

HW>                 <fencedevice agent="fence_ilo"
HW> hostname="10.10.10.2" login="Administrator" name="HPiLO_node2"
HW> passwd="QWD31D4D"/>

HW>         </fencedevices>


-- 
Best regards,
 Vlad                            mailto:vlad nkmz donetsk ua



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]