[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Magma build issues



I've got an odd one here. I've tried this with both the Fedora Development
magma-1.0.2-1.src.rpm as well as the code from the cluster cvs RHEL4 tag
(run through build_srpms.pl). 

Magma builds fine, however when trying to install the resulting RPM, it
seems to depend on itself. 

[root finite RPMS]# rpm -Uvh magma-1.0.2-20051110170622.i386.rpm 
error: Failed dependencies:
        libmagma.so is needed by magma-1.0.2-20051110170622.i386
        libmagmamsg.so is needed by magma-1.0.2-20051110170622.i386

[root finite RPMS]# rpm -qp --provides magma-1.0.2-20051110170622.i386.rpm 
libmagma.so.1.0.2.20051110170622  
libmagma_nt.so.1.0.2.20051110170622  
libmagmamsg.so.1.0.2.20051110170622  
magma = 1.0.2-20051110170622

[root finite RPMS]# rpm -qp --requires magma-1.0.2-20051110170622.i386.rpm 
/sbin/ldconfig  
/sbin/ldconfig  
libc.so.6  
libc.so.6(GLIBC_2.0)  
libc.so.6(GLIBC_2.1)  
libc.so.6(GLIBC_2.1.3)  
libdl.so.2  
libdl.so.2(GLIBC_2.0)  
libdl.so.2(GLIBC_2.1)  
libmagma.so  
libmagma.so.1.0.2.20051110170622  
libmagmamsg.so  
libpthread.so.0  
libpthread.so.0(GLIBC_2.0)  
libpthread.so.0(GLIBC_2.1)  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

Can anyone shed some light?

Thanks,
Matt

-- 
Matt Hyclak
Department of Mathematics 
Department of Social Work
Ohio University
(740) 593-1263



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]