[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] new cluster created when new node joins



on the existing blades in the cluster there's nothing in the logs.  on 
the entering blade, we get the "normal"

Oct  6 16:28:29 blade06 kernel: CMAN: Waiting to join or form a Linux-cluster
Oct  6 16:29:01 blade06 kernel: CMAN: forming a new cluster
Oct  6 16:29:01 blade06 kernel: CMAN: quorum regained, resuming activity
Oct  6 16:31:20 blade06 kernel: CMAN: we are leaving the cluster.
Oct  6 16:31:42 blade06 kernel: CMAN: Waiting to join or form a Linux-cluster
Oct  6 16:32:14 blade06 kernel: CMAN: forming a new cluster
Oct  6 16:32:14 blade06 kernel: CMAN: quorum regained, resuming activity

...so it seems like the messages aren't getting sent/received on the
mutlicast network.  I guess I'll try sniffing the network to see if the
messages are out there.

-dan

On 6, Oct, 2005, Jonathan E Brassow declared:

> Anything in /var/log/messages?
> 
> On Oct 6, 2005, at 5:06 PM, Dan B. Phung wrote:
> 
> > There is another cluster that is running orthogonal of this cluster, 
> > but
> > that's not defined in this cluster.xml.  The cluster.xml is the same
> > for both these machines.
> >
> >
> > On 6, Oct, 2005, Jonathan E Brassow declared:
> >
> >> do they have multiple clusters set up in their environment?  Does the
> >> /etc/cluster/cluster.xml file match the others?
> >>
> >>   brassow
> >>
> >> On Oct 6, 2005, at 3:37 PM, Dan B. Phung wrote:
> >>
> >>> I have an existing cluster:
> >>>
> >>> blade04: # cman_tool nodes
> >>> Node  Votes Exp Sts  Name
> >>>    1    1    1   X   blade01
> >>>    4    1    1   M   blade04
> >>>   11    1    1   M   blade11
> >>>
> >>> then blade06 joins the cluster, but instead of joining the existing
> >>> cluster, it creates a new one:
> >>>
> >>> blade06: # cman_tool nodes
> >>> Node  Votes Exp Sts  Name
> >>>    6    1    1   M   blade06
> >>>
> >>> Both machines are using Protocol version: 5.0.1
> >>>
> >>> How can I further debug why this is happening?
> >>>
> >>> thanks,
> >>> dan
> >>>
> >>> --
> >>> Linux-cluster mailing list
> >>> Linux-cluster redhat com
> >>> https://www.redhat.com/mailman/listinfo/linux-cluster
> >>>
> >>
> >> --
> >> Linux-cluster mailing list
> >> Linux-cluster redhat com
> >> https://www.redhat.com/mailman/listinfo/linux-cluster
> >>
> >
> > -- 
> > email:  phung cs columbia edu
> > www:    http://www.cs.columbia.edu/~phung
> > phone:  646-775-6090
> > fax:    212-666-0140
> > office: CS Dept. 520, 1214 Amsterdam Ave., MC 0401, New York, NY 10027
> >
> > --
> > Linux-cluster mailing list
> > Linux-cluster redhat com
> > https://www.redhat.com/mailman/listinfo/linux-cluster
> >
> 
> --
> Linux-cluster mailing list
> Linux-cluster redhat com
> https://www.redhat.com/mailman/listinfo/linux-cluster
> 

-- 
email:  phung cs columbia edu
www:    http://www.cs.columbia.edu/~phung
phone:  646-775-6090
fax:    212-666-0140
office: CS Dept. 520, 1214 Amsterdam Ave., MC 0401, New York, NY 10027


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]