[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-cluster] umount failed - device is busy





Lon Hohberger wrote:
On Mon, 2005-10-10 at 22:06 +0200, Herta Van den Eynde wrote:


Did you try enabling force unmount in the device/file system
configuration?

-- Lon

Thanks for the explanation, Lon. Yes, the devices are configured for "Force Unmount". With the device unmounted on all of the nfs clients I even tried to 'umount -f' manually, but I got the same result.


Odd.  Well, "umount -f" actually doesn't do what most people think it
does.

The "force unmount" option looks for and kills any user-land process
holding a reference on the file system using "kill -9".

So, if you're getting EBUSY on unmount even though force-unmount is
working (confirmed by you looking at lsof/fuser), chances are good that
there's a kernel reference on the file system.

It could be something NFS related - try "service nfs stop" and see if
you can umount the file system.

-- Lon

Unfortunately, this is a production cluster which serves well over 100,000 users (e-learning environment for our university, a dozen associated colleges, and a few hundred K-12 institutions) and I only have 4 hour maintenance windows on the 7th of each month, so stopping all of nfs is not an option today. :-( One of the cluster services is used for admin purposes, and that's the only one I can currently use (within limits) to test suggestions.

FWIIW, I don't think the force unmount works. True, lsof/fuser don't report processes against the filesystem, but "df" and "mount" show that it's still there, and I can write to and read from it after I try a "umount -f".

Kind regards,

Herta


Disclaimer: http://www.kuleuven.be/cwis/email_disclaimer.htm


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]